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USB cable 

Scale indicator 

Back piece & 

Height sensor 

Scale platform 

Calibration cube 

Scale hardware 
• Qty 3 M6 – 1.0 x 14 screws 

• Qty 3 M8 – .9 x 12 screws 

• Qty 1 M4 – Hex key tool 

• Qty 1 M3 – Hex key tool 
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Assemble the back piece and height sensor with the scale platform as shown in pictures.  

Be sure to mount the back piece at a right angle. 

 

 

  

 
to the picture.  
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New models have USB cable 
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Software installation 

 
Make sure to carefully follow the installation instructions below 
Only with Windows 7. Windows 10 will automaticaly install USB serial driver. 
 
Log in as Administrator to install the software and drivers. 
 
Download serial driver 
www.parcelcube.com/support/serial_installer.exe 
Run the serial installer, again as administrator 
 

Insert the USB cable into the PC. The found new hardware wizard will install the USB Seriial 
interface 
 
Download Software 
www.parcelcube.com/support/pcclientlatest.zip 
Extract to your final desitnation (where  you will run the software from normaly c:\) 
 
 
Run setup.exe (located in c:\parcelcube R2\publish) 

1. Click Run 

 
 
2. Click Install 
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Once installation is finished, you will be presented with the below window. 
 

 
 
The software is pre-configured, although there are some settings that need to be adjusted. 
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Determine which serial port the scale was assigned to by navigating to the Device Manager  
(Start > Control Panel > Device Manager). Look for USB serial port (COMx) as shown above. 
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Click Edit > Admin login to enable the configuration menu item. 
The password is dimwei. 
Click Edit > Configuration to open the configuration window. 
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1 Check Metric and Smoothing check boxes. 
2 Check Indicator connected check box and select RinstrumR320. 
3 Set the Bind to IP address to the computer’s IP address. 
4 Enter the Dim factor for your freight company. 
5 Choose the COM Port in the drop down box that corresponds 
to the scale serial port shown in Device Manager. 
 
l Click Save. 
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The scale is pre-calibrated for weight, but the dimensioning system must be calibrated. 
l Click Edit > Auto Calibrate dimensions. 
l Follow the on screen instructions.  
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1 File menu 
2 Edit menu 
3 Start the scale software communication with the hardware and Webservice 
4 Toggle Metric or Imperial units. 
5 Measured objects length (L) 
6 Measured objects width (W) 
7 Measured objects height (H) 
8 Volume in (L x W x H) 
9 Weight 
10 Volume weight (calculated from dimensions and dim weight) 
11 Green if weight > Volume Weight. Red if volume weight > Weight 
12 Save all measurement data and additional information as User defined fields in .csv file. 
If you have configured Remote Webservice uri, a call will also be made with all the data. 
13 Seven (7) User definable fields. First field will always have focus at program startup and 
after registering data. 
14 Number of items stacked along the length 
15 Length per item 
16 Number of items stacked along the width 
17 Width per item 
18 Number of items stacked along the height 
19 Height per item 
20 Weight per item 
21 Set the weight for 10 pcs 
22 Number of pcs 

23 camera preview (only displayed if camera is licensed and enables) 
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You must click Save to apply any changes to the configuration and re-starting the software is 
recommended. 

 

1 Scale table dimensions in cm – Calibration values for dimensioning 

2 High res – Dimensions measured with 1 decimal 

Smoothing – Stabilizes the dimensional measurements 

Imperial – Use imperial measurements instead of metric 

Camera – Enables USB camera interface 

Auto RUN – Automatically runs scale software when PC is restarted 

mm / liter Not used 

 
Continues on next page. 
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3 Indicator connected – Must be checked and RinstrumR320 must be selected 
4 CSV directory – Location where the .csv file will be saved as well as pictures from camera 
5 WebServer API – IP address and port the scale software will bind to 
6 Remote Webservice uri – See pages 18–21 
7 a User defined values – Rename the 7 user-defined fields of additional data saved with the 
.csv file. 
Each field can be configured to clear after enter. 
b User value can be used to add prefix to pictures standard date-time based file name. 
8 Scale calibration – Not used 
9 Dim Factor – Freight carrier dimensional weight factor 
10 COM Port – Serial port of PC used to connect to the scale 
11 F9 Configuration – See page 15 
12 Secondary display – Not used 

13 Camera settings 

14 Aiming tool to aim laser, Not used on SN1 and BN1 models 
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Item stacking 
If you wish to measure many small objects (smaller than the minimum size allowed) you can 
use item stacking. As an example, if you have 200 business cards, stack them along the 
height, put in 200 in the height pcs field. The field height will show total height and the field 
size per item under item stacking will show the size of each business card. 
 
Measuring oversized objects 
If you have an object too big to fit on the scale, you can still use the scale to register the 
data. Under File menu choose Pause Serial. Now you can manually enter the dimensions and 
weight. Register the data and when complete, click File menu and choose Start Serial. 
 
F9 configuration 
This option allows you to configure the scale software to emulate a keyboard typing in the 
volume and weight data to any application. Say you want to save the measurements to an 
Excel file with the column layed out as: 
Length Width Height Weight 
You configure the F9 as l,t,w,t,h,t,W,lf 
The Excel file will be filled in when you press the F9 key: (fictional volume and weight data) 
Length Width Height Weight 
23 41 12 0.77 
43 23 12 1.33 
 
Auto calibrating dimensions 
To do an auto calibration you need to be logged in as admin in the software. Edit > Admin 
login (password dimwei). Once logged in you have access to Edit > Auto calibrate 
dimensions. You need to follow the on-screen instruction and have the calibration object. 
Make sure you followed the steps outlined during assembly, installation and start-up. 
Choose Edit > Admin login to enable configuration (password is dimwei) 
Choose Edit > Configuration to open up the configuration window. Select High res, ensuring 
that Smoothing is NOT selected. 
Click Save and OK. 
Position the main window and configuration windows so that you can see both windows at 
the same time. 
 
Calibrate dimensions (Must be done using centimeters, not inches) 
Place an object of known size, for example 20 x 20 x 20 cm (8 x 8 x 8 in) and preferably made 
of wood or metal on the scale. Observe the dimensions in the main window. If a dimension, 
such as width, is listed as too small, such as 19.5, in the configuration window, manually 
change the width under Table Dimensions in cm to current value + (20 – 19.5). So if the 
current value was 63.5 you would change it to 64. If, for example, the length shows as 20.5 
you would then decrease the current length value according to current value – (20.5 – 20). 
Thus, if the current value was 64.5 you would then change it to 64. 
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File > View CSV 

 

This option will bring up a view of the current CSV data. 
The CSV file is located in the path defined in the configuration form. 
 
The scale CSV file format is as follows: 

Field 1 Date and time in computer’s current format, variable size 
Field 2 Length, variable size 
Field 3 Width, variable size 
Field 4 Height, variable size 
Field 5 Volume, variable size 
Field 6 Weight, variable size 
Field 7 Volume Weight, variable size 
Field 8 User Value 1, variable size 
Field 9 User Value 2, variable size 
Field 10 User Value 3, variable size 
Field 11 User Value 4, variable size 
Field 12 User Value 5, variable size 
Field 13 User Value 6, variable size 
Field 14 User Value 7, variable size 
Field 15 Item stacking length, variable size 
Field 16 Item stacking width, variable size 
Field 17 Item stacking height, variable size 
Field 18 Item stacking weight, variable size 
Field 19 Item counting # of pcs 

Each field ends with a semicolon except the last field, which ends with CRLF. 
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Indicator Zero / Span Calibration Procedure 

With the indicator powered on and in normal weighing mode, perform the following 

functions  to calibrate the Rinstrum scale indicator.  

1. Press  Power & “F” key together for 2 seconds to access setup mode. 

2. Press  ZERO key (2X) until CAL Menu is displayed. 

3. Press  TARE key (1X) and “ZERO” will be displayed. 

4. Remove all weight from the scale platform. 

5. Press  GROSS/NET Key (1X). Display will flash current weight. 

6. Press  PRINT key (1X). Display shows “Z in P” (Zero in Process) followed by the newly 

captured  zero reference flashing on the display. 

7. Press  TARE key (1X) to return to ZERO menu. 

8. Press  TARE key again (1X) to display SPAN menu. 

9. Press  GROSS/NET key (1X). Display will flash current weight. 

10. Add calibration weight to scale platform. 

11. Press   GROSS/NET key (1X) to enter the calibration weight value.  

  

    GROSS/NET will select the digit. 

     PRINT will edit the digit (scroll up). 

12. Press  “F” key to accept weight value and perform calibration. Display shows “S in P”  

(Span in Process) followed by the newly captured span reference flashing on the display. 

13. Press  Power & “F” keys together for 2 seconds to save settings – and exit. 
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Indicator: Enabling Unit Switching 

With the indicator powered on and in normal weighing mode, perform the 

following  functions to enable unit switching on the indicator (NOT PC interface). 

1. Press  Power & “F” Key together for 2 seconds to access setup mode. 

2. Press  ZERO key (3X) until SPEC Menu is displayed. 

3. Press  TARE key (9X) until PUR.FN parameter is displayed. 

4. Press  GROSS/NET Key (1X). Display will show the current setting “NONE” by default. 

5. Press  PRINT key (1X) to change the setting to “UNITS”. 

6. Press  “F” key to accept the new value and return to PWR.FN. 

Press  Power & “F” keys together for 2 seconds to save settings and exit. 
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There are two methods for retrieving data from the ParcelCube client software. These 
methods are theWebservice and the Remote Webservice uri. The Webservice is used to pull 
data from the ParcelCube client and the Remote Webservice uri is used to push data from 
the ParcelCube client to a web service that is awaiting the data. 
 
1. Webservice (pull data) 
In order to utilize the Webservice for pulling data from the ParcelCube client there must be 
software written (web or desktop) to perform an HTTPWebRequest (e.g. button or link click). 
The web request must be made to the PC where the ParcelCube client software resides. 
 
Example c# code: 
--------------------------------------------------------------------------------------------------------------------------- 
Dim request As HttpWebRequest = 
CType(WebRequest.Create("http://192.168.43.37:8080/"), HttpWebRequest) 
// IP and port should be the one in the parcelcube config 
Dim response As HttpWebResponse = CType(request.GetResponse(), HttpWebResponse) 
' Get the stream associated with the response. 
Dim receiveStream As Stream = response.GetResponseStream() 
' Pipes the stream to a higher level stream reader with the required encoding format. 
Dim readStream As New StreamReader(receiveStream, Encoding.UTF8) 
'MsgBox(readStream.ReadToEnd()) 
Dim parcelcube_string() As String 
Try 
parcelcube_string = readStream.ReadToEnd().Split(";") 
Catch 
End Try 
item_lenght_txtbox.Text = parcelcube_string(0) 
item_width_txtbox.Text = parcelcube_string(1) 
item_height_txtbox.Text = parcelcube_string(2) 
item_weight_txtbox.Text = parcelcube_string(4) 
response.Close() 
readStream.Close() 
--------------------------------------------------------------------------------------------------------------------------- 
parcelcube_string() has all the data, even though this example only uses 4 values. If you 
want the calculated volume 
parcelcube_string(3) will hold it. 

  

mailto:support@parcelcube.com
http://www.parcelcube.com/support


 

 
Email. support@parcelcube.com 
Web. www.parcelcube.com/support  Page 20 

 
 
Configure ParcelCube client Web Service 
 
In the ParcelCube client software configuration screen fill in the following fields: 
1 Bind to IP Address – This is the IP address of the PC that is running the ParcelCube 
client software (127.0.0.1 may be used for testing locally on the PC). 
2 Bind to Port – Enter the port number. 
* Note – If you have problems connecting, verify that the port entered is allowed in your 
firewall. 

 
 
Test Connectivity 
To test connectivity on your network PC. With the ParcelCube client software running, enter 
http://192.168.10.80:8080 (substitute your IP and Port) using either Microsoft Internet 
Explorer or Mozilla Firefox on a network PC. After you press the Enter key the ParcelCube 
client should return the following: 
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2. Remote Webservice uri (push data) 

 

In order to utilize the Remote Webservice uri for pushing data from the ParcelCube client to 
your host application there must be a web service written and running that has a variable 
waiting to be populated (e.g. variable named data). 
 
Example : 
The web server that is running your web service has an ip address of 192.168.10.20 and uses 
port 9090. 
Your web service name is pcdata and contains a variable that is expecting an http: get. The 
uri that you would put into the Remote Webservice uri in the ParcelCube client would be as  
 
follows: 
http://192.168.10.20:9090/pcdata?data 
ip address port webservice?variable 
 
Configure ParcelCube client 
In the ParcelCube client software configuration screen fill in the following field: 
• Remote Webservice uri 
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Usage 
 
Once your web service is in place and you have configured the Remote Webservice uri in the 
ParcelCube client you simply click on the Register (Enter) button in the ParcelCube client 
software and it will be retrieved by the web service in the format. 
 
 
 
Example of data returned to your web service: 
http://192.168.10.20:9090/pcdata?data=12;8.6;6.5;0.388194;1.5;4.041; ; ; ; ; ; ;12;8.6;6.5 
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